読者です 読者をやめる 読者になる 読者になる

Maven 3.2.x でなくて、3.3.x を使うべき。

Maven 3.2.3 環境で、Eclipse Maven ビルド実行していたら、、
コンパイルエラー
ラムダ式は-source 1.5でサポートされていません
(ラムダ式を使用可能にするには、-source 8以上を使用してください)


が発生してしまった。なぜ?

Maven 3.3.9 zipをダウンロードして展開し、MAVEN_HOME をダウンロードして展開したディレクトリに変更して
Eclipse を再起動、→ ビルドで成功